Always happy to kick around ideas. I like the “very-” / “very+” idea; allows for context to be considered. Perhaps a generic set of hedge—, hedge–, hedge-, hedge+, hedge++, hedge+++ that can be named dynamically as part of creating the rule block. The formulae are fixed, but the names are user-definable.
Need to learn more Java before I can start registering my own hedges with HedgeFactory. 🙂