home Forums # Technical Support Conversion errors


Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #2180


    I’ve just tried to compile one of the examples with version 5.0 on Windows and MINGW-32bit compiler. However, I get a bunch of conversion errors like:

    invalid conversion from ‘long int’ to ‘const fl::Term*’ [-fpermissive]
    Activated(const Term* term = fl::null, scalar degree = 1.0,


    invalid conversion from ‘long int’ to ‘fl::Function::Node*’ [-fpermissive]
    Node(Element* element, Node* left = fl::null, Node* right = fl::null);

    What am I doing wrong? Thanks for any help in advance!


    Ok, I now compiled fuzzylite for MSVC 64bit and it works just fine. Obviously MSVC is more forgiving than MINGW.


    Hi Ana,

    thank you for your post.

    The error you are seeing might be because you are not passing compile flag FL_CPP11. In your project, I think you need to add the preprocessor definition -DFL_CPP11.

    I have worked only on making sure everything runs fine in MSVC (2010-2015, [32|64]bit) and Unix (Mac OSX|ubuntu, [32|64]bit, clang|g++). I never managed (or tried hard) to get mingw running on my virtual box, and hence I do not know how or what fuzzylite needs in order to compile in mingw. Regardless, I reckon it is better to use MSVC than mingw because with mingw you would need to link to some additional libraries (or at least that is what I recall from a few years ago).

    Anyway, if you make it run on mingw, it would be great if you let me know the necessary steps to have it compile there.



    Thanks for your reply! Right now I’m quite happy with using the MSVC version, so I think I’ll stick with it. However, if I should make any progress with MingW I’ll let you now.


Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.